Summary/Issue Description
When attempting to launch CX-Programmer, the software does not start. Instead, a pop up window appears stating that a CX-Server update is available, but the program does not allow the update to proceed.
Root Cause
The Windows update program (KB5064081 or KB5065426) may delete DLL files installed by the CX-Server updater. As a result, when CX-Programmer is launched, Windows detects missing files and automatically executes a repair process for the CX-Server updater.
Solution
Omron has released a patch to fix this issue. You can download the patch along with the installation instructions from the following link.
Patch Download: https://www.fa.omron.co.jp/product/tool/26/cxone/windows/download.html
Omron has scheduled a CX-One update mid to late October.
Date/Revision History
First review 09/25/2025 V1.0
Second review 09/25/2025 V1.1
Author:
Hector Vega, Technical Support Engineer
References
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