TN – CXONE Patch for CX-Server Error after MicroSoft Update on W11

Modified on Tue, 14 Oct at 8:38 AM

Summary/Issue Description

When launching CXONE applications that use CXServer, like CXProgrammer, the message “The feature you are trying to use is on a network resource that is unavailable” appears. The application does not run.

 

Example

 

Conditions of Recurrence

Some applications of CX-One that use CX-Server, such as CX-Programmer, may fail to start if all the following conditions are met:

Using Windows 11 

Applied Windows update KB5064081 (August 29, 2025) or KB5065426 (September 9, 2025)

Updated the common modules of CX-One / Sysmac Studio in the past.

 

Root Cause

Due to the Windows updates (KB5064081/KB5065426), the system file (CTL3D32.DLL) required by the CX-One application is deleted. As a result, when starting the CX-One application, the Windows system detects the absence of the target file and initiates a repair process. If the user has administrative privileges, the repair is performed automatically. However, if the information required for the repair is corrupted or deleted, the automatic repair cannot be performed, and the user is prompted to enter the path to the installation package for the repair.

 

 

Solution

  1. For customer reply, please refer to Suggested Customer Reply CX-Server Patch.docx because customer needs to agree to the terms of the software license agreement found here:

 https://www.fa.omron.co.jp/product/tool/26/cxone/windows/

 

  1. Before starting the upgrade of CX-Server, please confirm the following points:
  1. Log in as an administrator or a user with administrator privileges.
  2. Close all Windows programs.
  3. Please execute the following:
  1. Please execute the following:
  1. Please copy CX-Server_5_1_1_6.zip to a local drive on your PC (see attached).
  2. Restart your PC. (This step is mandatory.)
  1. Note: After restarting, do not launch any CX-One related software.
  1. Right-click the file CX-Server_5_1_1_6.zip and ensure the security flag is set to “Allow” before proceeding.
  2. Extract all contents of CX-Server_5_1_1_6.zip.
  3. Run setup.exe located in the extracted CX-Server_5_1_1_6 folder to update CX-Server. 
  1. Double-clicking the file will start the update installation. 
  2. Follow the on-screen instructions to complete the installation.
  3. Confirm that the CX-Server version is Ver.5.1.1.6.

 

Appendix

  1. How to check windows updates
  1. From the Windows Control Panel, select [Programs].
  2. In the [Programs and Features] screen, select [View installed updates] from the items in the left pane.
  3. When the issue occurs, the relevant updates will be displayed.

 

  1. How to Check the Version of CX-Server
  1. From the Windows Start menu, select [OMRON] - [CX-One].
  2. In the displayed Windows Explorer, double-click [CX-One Information].
  3. Check the version of CX-Server on the displayed screen

 

Date/Revision History

First review 9/23/2025 V1.0

 

Author:

Ed Gallagher-Technical Support Specialist

 

References:

https://www.fa.omron.co.jp/product/tool/26/cxone/windows/

 

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