Summary/Issue Description
"Provider not found on this PC" error shown in CX-Supervisor, which does not allow the users to connect to their databases and track the variables.
Root Cause
The "Provider not found on this PC" error in CX-Supervisor usually indicates that the OLE DB (Object Linking And Embedding Data Base) provider or ODBC driver (Open Data Base Connectivity) required to connect to the Microsoft Access database is not installed or is not available on your system. Here are some detailed steps to troubleshoot this issue:
Solution
1. Verify the Access Database Engine Installation
Make sure that you have the Access Database Engine installed on your system. This engine includes the OLE DB providers and ODBC drivers required to connect to Access databases.
You can download and install the Microsoft Access Database Engine from the Microsoft website:
Download Microsoft Access Database Engine
Make sure to install the version that matches your operating system architecture (32-bit or 64-bit).
2. Check Architecture (32-bit vs. 64-bit)
Make sure that CX-Supervisor and the Access database engine (or other relevant software) are of the same architecture (32-bit or 64-bit). If CX-Supervisor is a 32-bit application, you need to install the 32-bit version of the Access database engine, even if your operating system is 64-bit.
3. Check the Connection String
Make sure that the connection string you are using in CX-Supervisor is correct. Here is an example of an OLE DB and ODBC connection string for Microsoft Access, if you are using OLE DB Jet Connection your connection string should look like this:
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\path\to\your\database.mdb;
Date/Revision History
First Review: 12/20/2024
2nd Review: 01/22/2025
Author:
Karla Flores Avila, Technical Support Specialist
References
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