Summary/Issue Description
This LVS-95XX software start up error can mean that the LVS camera hardware has failed. This failure is not a field recoverable failure. The LVS device will need to be sent in for repair.
Root Cause
The original error for this failure was a failure to launch error. The error message was, “Error 13: Type mismatch”. This error is a little bit misleading because it also can mean that there is an issue with the software’s database file. The LVS software was updated in version 4.2.1.3004 to throw an easier to understand error, “Invalid Camera Serial Number”.
Solution
Software Update:
Version | Release Date | Comment |
4.2.1.3004 | 04-Oct-2017 | TTP 16306: Gracefully detect and complain about non-numeric camera serial numbers |
If you have the LVS software version 4.2.1.3004 or newer, you will see the error message below. Your device will need to be sent in for repair.
If you have a LVS software version lower than 4.2.1.3004, you will see the error message below. This error needs further investigation to determine the failure type.
If you see the LVS error, “13: type mismatch” and you have a LVS software version lower than 4.2.1.3004, see the options below for further instructions on determining if the device needs to be sent in for repair.
- Upgrade the LVS software to a version higher than version 4.2.1.3004. If you get the Invalid camera serial number error, then the device will need to be sent in for repair.
- Install the IC Capture software from The Imaging Source Company. The software will tell you what the Camera's serial number is. If the serial number is anything other than numbers, then the camera has had a hardware failure and the device will need to be sent in for repair. See the IC Capture software screenshot below.
If you continue to get the Error 13: type mismatch after upgrading the LVS software to a version 4.2.1.3004 or newer, follow the instructions below.
The "Run-time error '13': Type mismatch" error may appear, preventing a user from opening the LVS-95XX software. This error indicates that the software is unable to find the .mdb Access Database file for the verifier. Each verifier has one of these files that is serialized to the specific unit, and the software needs to see it and match it to the attached verifier prior to opening (see screenshot below).
The error is caused by one of two things:
1. The path to the .mdb file has been changed to an incorrect location in the LVS-95XX software under "Archive" > "Change SQL connection" (see screenshots below).
2. The file has been moved without changing the path in the LVS-95XX software.
Fix for Instance 1:
Move the .mdb file back to the location indicated in the LVS-95XX software.
Fix for Instance 2:
The first option is to move the file back to its original location, then change the location in the software to the new desired location, at which point you can move the file to the new location. The second option is to modify the Windows Regsitry key for the LVS-95XX software with the correct file path. Use the screenshot below as a guide on where to find this key and where to modify it.
If you still continue to have issues call Omron Technical support for further evaluation.
Date/Revision History
Published 7/15/2025 V1.0
Author:
Anthony Rosario, Technical Support Specialist
References
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